Having problem with rescript installetion

its after i run the npm run build command.

also have folder of react starter but not sure how to merge them.

thats the log file:

0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Users\itzik\.npm-global\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘run’,
1 verbose cli ‘build’
1 verbose cli ]
2 info using npm@6.14.11
3 info using node@v15.5.1
4 verbose run-script [ ‘prebuild’, ‘build’, ‘postbuild’ ]
5 info lifecycle rescript-project-template@0.0.1~prebuild: rescript-project-template@0.0.1
6 info lifecycle rescript-project-template@0.0.1~build: rescript-project-template@0.0.1
7 verbose lifecycle rescript-project-template@0.0.1~build: unsafe-perm in lifecycle true
8 verbose lifecycle rescript-project-template@0.0.1~build: PATH: C:\Users\itzik.npm-global\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\Users\itzik\Desktop\לימודים\FE-301 Full Stack- Client Side\rescript-project-template\node_modules.bin;C:\Users\itzik\AppData\Local\Programs\Python\Python39\Scripts;C:\Users\itzik\AppData\Local\Programs\Python\Python39;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0;C:\windows\System32\OpenSSH;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Program Files\Microsoft SQL Server\130\Tools\Binn;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn;C:\Program Files\dotnet;C:\Program Files (x86)\dotnet;C:\Program Files\erl10.3\bin;C:\Program Files (x86)\Yarn\bin;C:\ProgramData\chocolatey\bin;C:\Program Files\Git\cmd;C:\Program Files\nodejs;C:\Users\itzik.cargo\bin;C:\Users\itzik\AppData\Local\Microsoft\WindowsApps;C:\Users\itzik\AppData\Local\Programs\Microsoft VS Code\bin;C:\Program Files\JetBrains\PyCharm Community Edition 2020.2.3\bin;C:\Users\itzik.dotnet\tools;C:\Program Files\JetBrains\PyCharm Community Edition 2020.3.2\bin;;C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2020.3.1\bin;;C:\Users\itzik\AppData\Local\Yarn\bin;C:\Users\itzik\AppData\Roaming\npm;C:\Users\itzik.dotnet\tools
9 verbose lifecycle rescript-project-template@0.0.1~build: CWD: C:\Users\itzik\Desktop\לימודים\FE-301 Full Stack- Client Side\rescript-project-template
10 silly lifecycle rescript-project-template@0.0.1~build: Args: [ ‘/d /s /c’, ‘bsb -make-world’ ]
11 silly lifecycle rescript-project-template@0.0.1~build: Returned: code: 2 signal: null
12 info lifecycle rescript-project-template@0.0.1~build: Failed to exec build script
13 verbose stack Error: rescript-project-template@0.0.1 build: bsb -make-world
13 verbose stack Exit status 2
13 verbose stack at EventEmitter. (C:\Users\itzik.npm-global\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
13 verbose stack at EventEmitter.emit (node:events:376:20)
13 verbose stack at ChildProcess. (C:\Users\itzik.npm-global\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack at ChildProcess.emit (node:events:376:20)
13 verbose stack at maybeClose (node:internal/child_process:1063:16)
13 verbose stack at Process.ChildProcess._handle.onexit (node:internal/child_process:295:5)
14 verbose pkgid rescript-project-template@0.0.1
15 verbose cwd C:\Users\itzik\Desktop\לימודים\FE-301 Full Stack- Client Side\rescript-project-template
16 verbose Windows_NT 10.0.19042
17 verbose argv “C:\Program Files\nodejs\node.exe” “C:\Users\itzik\.npm-global\node_modules\npm\bin\npm-cli.js” “run” “build”
18 verbose node v15.5.1
19 verbose npm v6.14.11
20 error code ELIFECYCLE
21 error errno 2
22 error rescript-project-template@0.0.1 build: bsb -make-world
22 error Exit status 2
23 error Failed at the rescript-project-template@0.0.1 build script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 2, true ]

also i tried the rescript react installation it didn’t work as well.
npm instsll works fine, npm start doesn’t.

a note the react installation worked just fine and it runs and everything.

can you try create a project with path not containing whitespace?
I am not sure if it is the issue, but "Full Stack " might look fishy

alright, no erroers, think it finished.
thanks mate.

but nothing also happend after: npx bsb -make-world
like commands ran and finished but idk is that it?

how do i about expusing modules?

if i move it to full stack now will it work?

will there be changes to it? because iam not gonna work on it now.
iam gonna start rescript react project some time soon.
its gonna be my final uni project.

but nothing also happend after: npx bsb -make-world
like commands ran and finished but idk is that it?

No news is good news. the generated js files should be in lib/ directory or in source with rescript