.res files build/compile issues on dev environment

Hello, me and my team at walnut.io are building our product using reasonml and recently moved to rescript. Some of my colleges and myself are experiencing an issue with bsb -w not watching .res files but keeps watching .re files.

I would appreciate any guidance with resolving the current issue, we already tried clean project setup (remove node_modules etc’… and installing everything from scratch). It fixed it, but only temporarily…

OSX version: 13.3.1
NodeJS version: 15.14.0

    "name": "@teamwalnut/app",
    "reason": {
        "react-jsx": 3
    "sources": [
            "dir": "src",
            "subdirs": true
    "bsc-flags": [
    "package-specs": [
            "module": "es6",
            "in-source": true
    "suffix": ".bs.js",
    "namespace": true,
    "ppx-flags": [
    "refmt": 3

Hello! Welcome. Got a repro?

Hey Cheng, thank you for replaying
I assume you meant ‘repo’ and that you are thinking of how to reproduce locally,
unfortunately its a private repo. perhaps we could try a different channel?

Just to be sure: Did you run bsb -clean-world and bsb -make-world already?

Which bs-platform version did you upgrade to?

yes ran bsb -clean-world and bsb -make-world
“bs-platform”: “9.0.1”

Do you use the reasonml-vscode plugin? Somehow I’ve got the feeling that this is the source of issue here.

I use both vscode IDE plugging:
reason-vscode (jaredly.reason-vscode)
rescript-vscode (chenglou92.rescript-vscode)

since we have “legacy” files written in .re, if that is the case? which plugin configuration might cause my issue that i can perhaps turn off?

The rescript-vscode plugin doesn’t touch .re files at all.

The issue i’m facing is only on .res files
everything regarding .re files works perfectly

The reasonml-vscode plugin does a bunch of things including calling the build directly, compiling files individually etc. It’s not recommended to run it in parallel.
If you have no other choice, it’s understandable, but also expect some issues like this one.

Thank you all for taking the time to replay, we’re running our projects with re:watch on each and it’s helping… I still face the current issue now and then, hopefully once we completely migrate to res it will be resolved.